Проектная работа по информатике Применение табличного процессора MS Excel для решения к



Оглавление

Введение.2

Решение квадратных уравнений через дискриминант с помощью табличного процессора MS Excel.4

Решение квадратных уравнений по теореме Виета с помощью табличного процессора MS Excel6

Решение квадратного уравнения графическим методом с помощью табличного процессора MS Excel11

Решение биквадратного уравнения в EXCEL.13

Заключение16

Литература17

«Недостойно одаренному человеку тратить, подобно рабу, часы на вычисления, которые, безусловно, можно было бы доверить любому лицу, если при этом применить машину»

Готфрид Лейбниц в XVII в

Введение.

Уравнения, зачем они нам нужны и где вообще встречаются? В поисках ответа на этот вопрос я просмотрела учебники химии, физики, алгебры и геометрии за 8 класс и оказалось, что в учебнике химии многие задачи решаются уравнением, в учебнике физики некоторые задачи решаются уравнением. В учебнике алгебры большинство задач можно решить уравнением, в геометрии 1-2%. Теория уравнений интересовала и интересует математиков всех времён и народов.

Первобытная мама по имени (впрочем, у неё и имени- то не было) сорвала с дерева 12 яблок и решила поделить их между своими четырьмя детьми. Она не умела считать ни до четырёх, ни до двенадцати. Она поступила так: дала каждому по одному яблоку, потом ещё по одному, потом ещё по одному, и увидела, что и яблок больше нет, и никто из детей не обижен.

Сегодня эту задачу можно решить уравнением 4х=12. Таким образом, уравнение, как метод решения задач, появился очень давно.

Необходимость решать уравнения не только первой, но и второй степени еще в древности была вызвана потребностью решать задачи, связанные с нахождением площадей земельных участков и с земляными работами военного характера, а также с развитием астрономии и самой математики.

Я задалась вопросом. А можно ли использовать компьютер для быстрого решения квадратного и биквадратного уравнений и как это сделать?

В данном проекте затрагиваются вопросы решения квадратных и биквадратных уравнений с помощью табличного процессора MS Excel. Я попыталась построить модель для решения квадратных уравнений с помощью алгебраического метода, по теореме Виета и графического метода, а также построила модель биквадратного уравнения.

Решение квадратных уравнений через дискриминант с помощью табличного процессора MS Excel.

Итак, моя задача сводилась к следующему: по известным коэффициентам квадратного уравнения вычислить дискриминант, сделать вывод о наличии корней и, если корни есть, найти их.

Начала я с составления блок-схемы:

начало

Ввод а, в, с

D= b2 – 4ac

D >= 0

да нет

Вывод х1,2

Уравнение корней не имеет

КОНЕЦ

В электронной таблице пользователю предоставляется возможность ввести любые коэффициенты квадратного уравнения. Благодаря введенным формулам в ЭТ вычисляется дискриминант и корни квадратного уравнения, если таковы имеются.

Ниже представлена технология решения квадратного уравнения в MS Excel : х2 — 3х + 2 = 0

1. В ячейки А14 введите соответственно тексты

«а=», «b=», «c=», «D=».

2. В ячейки В1:ВЗ введите соответствующие значения

коэффициентов: 1; -3; 2.

3. В ячейку В4 введите формулу =В2^2-4*В1*В3

(Если все сделали правильно, то в ячейке B4 будет число 1).

4. В ячейку А5 введите текст «Есть ли корни?».

5. В ячейку В5 введите формулу =ЕСЛИ(В4<0; "нет";"да").

6. В ячейку В6 введите формулу = ЕСЛИ(В4>=0;»х1=»;»»).

7. В ячейку В7 введите формулу = ЕСЛИ(В4>=0;»х2=»;»»),

8. В ячейку С6 введите формулу

= ЕСЛИ(В4>=0;(-В2+КОРЕНЬ(В4))/(2*В1);»»).

9. В ячейку С7 введите формулу

= ЕСЛИ(В4>=0;(-В2-КОРЕНЬ(В4))/(2*В1);»»).

Вот скриншот моей таблицы:

Решение квадратных уравнений по теореме Виета с помощью табличного процессора MS Excel

Нет формул важней

Для приведенного уравнения:

bЭто сумма его корней,

c Его корней произведение.

x1 + x2 = -b

x1 * x2 = c

Франсуа Виет заметил некоторую закономерность между корнями квадратного уравнения и его коэффициентами. Сегодня эта теорема в школьном учебнике алгебры звучит так: сумма корней приведённого квадратного уравнения равна второму коэффициенту, взятому с противоположным знаком, а произведение корней равно свободному члену.

Ниже представлена технология решения приведённого уравнения в MS Excel:

х2 + 2х — 3 = 0

1. В ячейки А3:А6 введите соответственно тексты

«а=», «b=», «c=», «D=».

2. В ячейки В3:В5 введите соответствующие значения коэффициентов: 1, 2, -3.

3. В ячейку В6 введите формулу =ЕСЛИ($B$3=1;$B$4^2-4*$B$5)

(Если все сделали правильно, то в ячейке В6 будет число 16).

В ячейку А7 введите текст «Есть ли корни?».

В ячейку В7 введите формулу =ЕСЛИ($B$6<0;"Корней нет!"Корни есть!»)

(Данная формула проверяет наличие корней у уравнения)

В ячейку В8 введите формулу =ЕСЛИ($B$3=1;(-$B$4+КОРЕНЬ($B$6))/2)

(Вычисляем первый корень)

В ячейку В9 введите формулу =ЕСЛИ($B$3=1;(-$B$4-КОРЕНЬ($B$6))/2)

(Вычисляем второй корень)

x1 + x2 = —

x1 * x2 =

Но оказывается, теорема Виета рассматривается шире, для любого квадратного уравнения.

Действительно, если: ах² + bх + с=0

Сделаем дополнения в нашу таблицу. Чтобы сделать уравнение приведённым, разделим каждое слагаемое на первый коэффициент и к полученному уравнению применим теорему Виета.

В ячейку С4 введем формулу =$B$4/$B$3

(делим второй коэффициент на первый b/a)

В ячейку С5 введем формулу =$B$5/$B$3

(делим третий коэффициент на первый с/a)

В ячейке В6 в формулу добавим =ЕСЛИ($B$3=1;$B$4^2-4*$B$5; $C$4^2-4*$C$5)

(дополненная формула позволяет вычислить дискриминант, при условии, если, а

В ячейке B8 в формулу вносим дополнения, =ЕСЛИ($B$3=1;(-$B$4+КОРЕНЬ($B$6))/2;(-$C$4+КОРЕНЬ($B$6))/2)

(Вычисляем первый корень)

В ячейке B9 в формулу вносим дополнения, =ЕСЛИ($B$3=1;(-$B$4-КОРЕНЬ($B$6))/2;(-$C$4-КОРЕНЬ($B$6))/2)

(Вычисляем второй корень)

Есть ещё способ, благодаря которому можно при определённых условиях сразу назвать корни уравнения.

Предположим, что а + b + с = 0, тогда b = с

дискриминант D=(-а-с)²-4ас=а²+2ас+с²-4ас=(а-с)2

тогда , а

т. е если сумма коэффициентов квадратного уравнения равна нулю, то мы сразу можем назвать корни. Внесем необходимые изменения в уже существующую таблицу:

В ячейку D3 введем формулу =ЕСЛИ($B$3+$B$4+$B$5=0;ИСТИНАОЖЬ)

(Данная формула проверяет условие, а+в+с=0 и если условие верно, то присваивается значение «ИСТИНА», в обратнос случае – «ЛОЖЬ»)

В ячейку D8 введем формулу =ЕСЛИ(D3=ИСТИНА;1;»данный способ не подходит»)

(это позволит при условии «ИСТИНА» первому корню уравнения присваивается 1, если «ЛОЖЬ», то данным способом уравнение решаться не будет)

В ячейку D9 введем формулу ЕСЛИ(D3=ИСТИНА;$B$5/$B$3;»данный способ не подходит»)

(это позволит при условии «ИСТИНА» вычислить второй корень уравнения как если «ЛОЖЬ», то данным способом уравнение решаться не будет).

Ну а если сумма первого коэффициента и свободного члена равна второму коэффициенту а + с = b, тогда:

D= (а+с) ²-4aс = а²+2ас+с²-4ас = (а-с) 2

Внесём необходимые формулы в табличный процессор MS Excel:

В ячейку Е3 введём формулу =ЕСЛИ(B3+B5=B4;ИСТИНАОЖЬ)

В ячейку Е8 введём формулу =ЕСЛИ(E3=ИСТИНА;-$B$5/$B$3;»данный способ не подходит»)

(при условии «ИСТИНА» вычисляет первый корень как ( — ) если «ЛОЖЬ», то данным способом уравнение решаться не будет)

В ячейку Е9 введём формулу =ЕСЛИ(E3=ИСТИНА;-1;»данный способ не подходит»)

(при условии «ИСТИНА» второму корню уравнения присваивается -1, если «ЛОЖЬ», то данным способом уравнение решаться не будет)

Также в таблицу можно добавить проверку формул теоремы Виета, если

x1 + x2 = -b

x1 * x2 = c

то уравнение является приведённым:

В ячейку А11 и А12 введём соответственно текст «x1 + x2 = —b?» «x1 * x2 = c?»

В ячейку В11 введём =ЕСЛИ(И($B$8+$B$9=-$B$4;B8*B9=B5);»Уравнение приведённое»;»Уравнение не является приведённым» )

Здесь представлен скриншот моей таблицы:

Решение квадратного уравнения графическим методом с помощью табличного процессора MS Excel

Графический метод часто применяют не для нахождения корней уравнения, а для определения их количества.

Если в уравнении х2 + bx + c = 0 перенести второй и третий члены в правую часть, то получим х2 = —bxc. Построив графики зависимости у = х2 и у = — bx c, на пересечении двух графиков можно определить не только количество корней, но и их значение.

Решим уравнение: х2 + 2х – 3 = 0.

Представим данное уравнение в следующем виде: х2 = – 2х + 3.

Чтобы решить данное уравнение, нужно найти такое значение х, при котором левая часть уравнения была бы равна правой. Введем две функции у1, равной левой части уравнения и у2, равной правой части уравнения. Теперь нужно найти такое значение х, при котором у1 = у2, т. е. общую точку, принадлежащую графику функции у1 и графику функции у2. Эта точка будет являться точкой пересечения графиков функций у1= х2 и у2= –2х + 3. Абсцисса точки пересечения будет являться решением исходного уравнения. Для этого составим таблицы их значений в MS Excel:

x

у1=х^2

у2=-2х+3

-4

16

11

-3,5

12,25

10

-3

9

9

-2,5

6,25

8

-2

4

7

-1,5

2,25

6

-1

1

5

-0,5

0,25

4

0

0

3

0,5

0,25

2

1

1

1

1,5

2,25

0

2

4

-1

2,5

6,25

-2

3

9

-3

3,5

12,25

-4

4

16

-5

у1 = х2 – график первой зависимости — парабола, проходящая через начало координат, у2 = –2х + 3 – график второй зависимости – пряма



Выделим столбцы у1 и у2 и построим график функций:

А(–3;9) и В (1;1) –точки пересечения.

Абсциссы этих точек равны –3 и 1.

Значит х1 = –3 и х2 = 1 – решение уравнения

Возможны следующие случаи:

— прямая и парабола могут пересекаться в двух точках, абсциссы точек пересечения являются корнями квадратного уравнения;

— прямая и парабола могут касаться ( только одна общая точка), т.е. уравнение имеет одно решение;

— прямая и парабола не имеют общих точек, т.е. квадратное уравнение не имеет корней.



Страницы: 1 | 2 | Весь текст




sitemap
sitemap